The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions.
History

Fri, 06 Nov 2026 14:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-200
CWE-285

Fri, 06 Nov 2026 12:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-269
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N'}


Fri, 06 Nov 2026 08:15:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions surfer
Vendors & Products Wordpress-extensions
Wordpress-extensions surfer

Fri, 06 Nov 2026 07:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-200
CWE-285

Fri, 06 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions.
Title Surfer < 1.8.1.759 - Contributor+ Privilege Escalation via Editor API Key Disclosure
References

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published: 2026-11-06T06:00:26.032Z

Updated: 2026-11-06T11:58:26.462Z

Reserved: 2026-10-28T17:18:28.308Z

Link: CVE-2026-118639

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-06T06:16:41.250

Modified: 2026-11-06T12:17:19.117

Link: CVE-2026-118639

cve-icon Redhat

No data.